# FeedWordPress <= 2026.0517 - Unauthenticated Stored Cross-Site Scripting via Syndicated Feed Content

- **ID:** WPSEC-2026-2257
- **Plugin:** FeedWordPress (`feedwordpress`), https://wordpress.org/plugins/feedwordpress/
- **Affected versions:** all versions before 2026.1016
- **Fixed in:** 2026.1016 (Update to 2026.1016 or later.)
- **Severity:** Medium 5.4 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/feedwordpress
- **Fix released:** 2026-10-30
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2257/

## Description

The FeedWordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via syndicated feed item content in all versions up to, and including, 2026.0517, due to the plugin deliberately removing WordPress's kses filters from content_save_pre before saving syndicated posts. As a result, raw feed HTML such as script tags, event handler attributes and javascript: URLs is stored without sanitization. This makes it possible for unauthenticated attackers who control, or can inject content into, a feed the site syndicates (for example a compromised feed or one that republishes user-submitted input) to inject arbitrary web scripts into posts that execute whenever a user, including an administrator, views the affected post.

Also published later by wordfence as CVE-2026-110530.

## References

- https://wpsec.com/vuln/WPSEC-2026-2257/
- https://plugins.svn.wordpress.org/feedwordpress/tags/2026.1016/
- https://wordpress.org/plugins/feedwordpress/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2257/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
