{
 "id": "WPSEC-2026-2259",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2259/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2259/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2259/index.md",
 "title": "Gutenberg WooCommerce Builder Blocks for ShopEngine, Variation Swatches, Wishlist, Products Compare <= 2.4.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'font_link' Parameter",
 "description": "The ShopEngine Gutenberg WooCommerce Builder Blocks Addon plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'font_link' parameter of the gutenova_store_css AJAX action in all versions up to, and including, 2.4.3 due to insufficient output escaping when the stored gutenova_font_link post meta is placed inside a double-quoted JavaScript string in the block editor's inline script. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts that execute whenever a user, such as an administrator, opens the affected post in the block editor.",
 "plugin": {
  "slug": "blocks-for-shopengine",
  "name": "Gutenberg WooCommerce Builder Blocks for ShopEngine, Variation Swatches, Wishlist, Products Compare",
  "full_name": "ShopEngine Gutenberg WooCommerce Builder Blocks Addon – All in One WooCommerce Solution",
  "wordpress_org": "https://wordpress.org/plugins/blocks-for-shopengine/",
  "advisories_url": "https://wpsec.com/vuln/plugin/blocks-for-shopengine/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/blocks-for-shopengine"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "2.4.4",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 2.4.4"
  ]
 },
 "introduced_in": null,
 "fixed_in": "2.4.4",
 "remediation": "Update to 2.4.4 or later.",
 "fix_released": "2026-11-02T11:18:31+00:00",
 "published": "2026-11-03T14:48:33+00:00",
 "updated": "2026-11-03T13:21:52.985084+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2259/",
  "https://plugins.svn.wordpress.org/blocks-for-shopengine/tags/2.4.4/",
  "https://wordpress.org/plugins/blocks-for-shopengine/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/blocks-for-shopengine",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-11-03"
 }
}