{
 "id": "WPSEC-2026-2263",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2263/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2263/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2263/index.md",
 "title": "Events Made Easy <= 3.3.2 - Unauthenticated Reflected Cross-Site Scripting via Event List Filter Parameters",
 "description": "The Events Made Easy plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the event list filter parameters (such as 'eme_city_filter', 'eme_cat_filter' or 'eme_scope_filter') in all versions up to, and including, 3.3.2, due to insufficient output escaping. On paged event lists the filter values are only passed through sanitize_text_field, which keeps quotes, then added to the previous and next page links with add_query_arg, which does not encode them, and printed into single-quoted href attributes without esc_url(). This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.",
 "plugin": {
  "slug": "events-made-easy",
  "name": "Events Made Easy",
  "full_name": "Events Made Easy",
  "wordpress_org": "https://wordpress.org/plugins/events-made-easy/",
  "advisories_url": "https://wpsec.com/vuln/plugin/events-made-easy/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/events-made-easy"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.1,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "3.3.3",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 3.3.3"
  ]
 },
 "introduced_in": null,
 "fixed_in": "3.3.3",
 "remediation": "Update to 3.3.3 or later.",
 "fix_released": "2026-10-30T23:05:16+00:00",
 "published": "2026-11-03T14:48:33+00:00",
 "updated": "2026-11-03T13:22:07.831888+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2263/",
  "https://plugins.svn.wordpress.org/events-made-easy/tags/3.3.3/",
  "https://wordpress.org/plugins/events-made-easy/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/events-made-easy",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-11-03"
 }
}