{
 "id": "WPSEC-2026-2268",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2268/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2268/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2268/index.md",
 "title": "Cozy Blocks <= 2.2.28 - Authenticated (Contributor+) Stored Cross-Site Scripting via Block Attributes",
 "description": "The Cozy Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via block attributes, such as the block client ID used by numerous blocks (e.g., Accordion, Advanced Tab, Container, Counter, Form) and the Quick View block's icon alignment attribute, in all versions up to, and including, 2.2.28. This is due to insufficient input sanitization and output escaping. The client ID was inserted raw into inline JavaScript and script variable names, and the alignment value was placed unescaped into an HTML class attribute. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "cozy-addons",
  "name": "Cozy Blocks",
  "full_name": "Cozy Blocks – Website Builder & Business Growth Toolkit | Popups, Lead Forms & Inbox",
  "wordpress_org": "https://wordpress.org/plugins/cozy-addons/",
  "advisories_url": "https://wpsec.com/vuln/plugin/cozy-addons/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/cozy-addons"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "2.2.29",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 2.2.29"
  ]
 },
 "introduced_in": null,
 "fixed_in": "2.2.29",
 "remediation": "Update to 2.2.29 or later.",
 "fix_released": "2026-10-31T14:42:51+00:00",
 "published": "2026-11-03T14:48:33+00:00",
 "updated": "2026-11-03T13:22:22.074069+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2268/",
  "https://plugins.svn.wordpress.org/cozy-addons/tags/2.2.29/",
  "https://wordpress.org/plugins/cozy-addons/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/cozy-addons",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-11-03"
 }
}