# Cozy Blocks <= 2.2.28 - Authenticated (Contributor+) Stored Cross-Site Scripting via Block Attributes

- **ID:** WPSEC-2026-2268
- **Plugin:** Cozy Blocks – Website Builder & Business Growth Toolkit | Popups, Lead Forms & Inbox (`cozy-addons`), https://wordpress.org/plugins/cozy-addons/
- **Affected versions:** all versions before 2.2.29
- **Fixed in:** 2.2.29 (Update to 2.2.29 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/cozy-addons
- **Fix released:** 2026-10-31
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2268/

## Description

The Cozy Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via block attributes, such as the block client ID used by numerous blocks (e.g., Accordion, Advanced Tab, Container, Counter, Form) and the Quick View block's icon alignment attribute, in all versions up to, and including, 2.2.28. This is due to insufficient input sanitization and output escaping. The client ID was inserted raw into inline JavaScript and script variable names, and the alignment value was placed unescaped into an HTML class attribute. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-2268/
- https://plugins.svn.wordpress.org/cozy-addons/tags/2.2.29/
- https://wordpress.org/plugins/cozy-addons/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2268/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
