{
 "id": "WPSEC-2026-2271",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2271/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2271/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2271/index.md",
 "title": "Stock Locations for WooCommerce <= 3.2.1 - Authenticated (Shop Manager+) Stored Cross-Site Scripting via Location Fields",
 "description": "The Stock Locations for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via location term fields (such as address, phone, opening timings, product page notice, email, priority and coordinates) in all versions up to, and including, 3.2.1 due to insufficient output escaping in the location edit form. This makes it possible for authenticated attackers, with shop manager-level access and above, to inject arbitrary web scripts that execute whenever a user accesses the location edit screen. This only affects installations where such users lack the unfiltered_html capability, such as multisite installations.",
 "plugin": {
  "slug": "stock-locations-for-woocommerce",
  "name": "Stock Locations for WooCommerce",
  "full_name": "Stock Locations for WooCommerce",
  "wordpress_org": "https://wordpress.org/plugins/stock-locations-for-woocommerce/",
  "advisories_url": "https://wpsec.com/vuln/plugin/stock-locations-for-woocommerce/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/stock-locations-for-woocommerce"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 4.4,
  "vector": "CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "3.2.2",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 3.2.2"
  ]
 },
 "introduced_in": null,
 "fixed_in": "3.2.2",
 "remediation": "Update to 3.2.2 or later.",
 "fix_released": "2026-10-31T15:32:03+00:00",
 "published": "2026-11-03T14:48:33+00:00",
 "updated": "2026-11-03T13:22:38.459914+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2271/",
  "https://plugins.svn.wordpress.org/stock-locations-for-woocommerce/tags/3.2.2/",
  "https://wordpress.org/plugins/stock-locations-for-woocommerce/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/stock-locations-for-woocommerce",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-11-03"
 }
}