# Stock Locations for WooCommerce <= 3.2.1 - Authenticated (Shop Manager+) Stored Cross-Site Scripting via Location Fields

- **ID:** WPSEC-2026-2271
- **Plugin:** Stock Locations for WooCommerce (`stock-locations-for-woocommerce`), https://wordpress.org/plugins/stock-locations-for-woocommerce/
- **Affected versions:** all versions before 3.2.2
- **Fixed in:** 3.2.2 (Update to 3.2.2 or later.)
- **Severity:** Medium 4.4 (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/stock-locations-for-woocommerce
- **Fix released:** 2026-10-31
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2271/

## Description

The Stock Locations for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via location term fields (such as address, phone, opening timings, product page notice, email, priority and coordinates) in all versions up to, and including, 3.2.1 due to insufficient output escaping in the location edit form. This makes it possible for authenticated attackers, with shop manager-level access and above, to inject arbitrary web scripts that execute whenever a user accesses the location edit screen. This only affects installations where such users lack the unfiltered_html capability, such as multisite installations.

## References

- https://wpsec.com/vuln/WPSEC-2026-2271/
- https://plugins.svn.wordpress.org/stock-locations-for-woocommerce/tags/3.2.2/
- https://wordpress.org/plugins/stock-locations-for-woocommerce/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2271/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
