{
 "id": "WPSEC-2026-2275",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2275/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2275/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2275/index.md",
 "title": "WCFM Membership – WooCommerce Memberships for Multivendor Marketplace <= 2.12.0 - Authenticated (Subscriber+) Membership Payment Bypass via PayPal IPN",
 "description": "The WCFM Membership – WooCommerce Memberships for Multivendor Marketplace plugin for WordPress is vulnerable to payment bypass via the PayPal IPN handler in all versions up to, and including, 2.12.0, due to the handler activating a pending member's plan on subscr_payment notifications without checking the amount received, on subscr_signup notifications for one-time plans without any amount check, and accepting one-time payments for recurring plans without checking them. This makes it possible for authenticated attackers with subscriber-level access, such as a membership applicant, to activate a paid membership while paying less than its price, or nothing at all, through a PayPal payment or subscription they build themselves.",
 "plugin": {
  "slug": "wc-multivendor-membership",
  "name": "WCFM Membership – WooCommerce Memberships for Multivendor Marketplace",
  "full_name": "WCFM Membership – WooCommerce Memberships for Multivendor Marketplace",
  "wordpress_org": "https://wordpress.org/plugins/wc-multivendor-membership/",
  "advisories_url": "https://wpsec.com/vuln/plugin/wc-multivendor-membership/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/wc-multivendor-membership"
 },
 "type": "BYPASS",
 "cwe": [
  "CWE-345"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 4.3,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "2.12.1",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 2.12.1"
  ]
 },
 "introduced_in": null,
 "fixed_in": "2.12.1",
 "remediation": "Update to 2.12.1 or later.",
 "fix_released": "2026-11-02T09:04:30+00:00",
 "published": "2026-11-03T14:48:33+00:00",
 "updated": "2026-11-03T13:22:46.928238+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2275/",
  "https://plugins.svn.wordpress.org/wc-multivendor-membership/tags/2.12.1/",
  "https://wordpress.org/plugins/wc-multivendor-membership/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/wc-multivendor-membership",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "None seen",
  "as_of": "2026-11-03"
 }
}