# WCFM Membership – WooCommerce Memberships for Multivendor Marketplace <= 2.12.0 - Authenticated (Vendor+) Missing Authorization to Membership Plan Change

- **ID:** WPSEC-2026-2276
- **Plugin:** WCFM Membership – WooCommerce Memberships for Multivendor Marketplace (`wc-multivendor-membership`), https://wordpress.org/plugins/wc-multivendor-membership/
- **Affected versions:** all versions before 2.12.1
- **Fixed in:** 2.12.1 (Update to 2.12.1 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-862
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wc-multivendor-membership
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2276/

## Description

The WCFM Membership – WooCommerce Memberships for Multivendor Marketplace plugin for WordPress is vulnerable to unauthorized modification of data via the wcfmvm_membership_change AJAX action in all versions up to, and including, 2.12.0, due to a capability check that accepts marketplace vendor roles for this administrator-only "Change or Upgrade" action and missing validation that the target plan is a published membership. This makes it possible for authenticated attackers with vendor-level access to move their own account onto any membership plan, including paid, disabled or unpublished plans, without paying for it.

## References

- https://wpsec.com/vuln/WPSEC-2026-2276/
- https://plugins.svn.wordpress.org/wc-multivendor-membership/tags/2.12.1/
- https://wordpress.org/plugins/wc-multivendor-membership/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2276/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
