{
 "id": "WPSEC-2026-2290",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2290/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2290/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2290/index.md",
 "title": "Product Slider for WooCommerce <= 2.9.0 - Authenticated (Administrator+) Stored Cross-Site Scripting via Custom JS Setting",
 "description": "The Reno Product Slider (formerly Product Slider for WooCommerce) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Custom JS setting in versions 2.8.7 up to, and including, 2.9.0. This is due to the plugin letting any user who can save its settings store the Custom JS option, which is only stripped of HTML tags and is then printed as an inline script on the front end, without checking for the unfiltered_html capability. This makes it possible for authenticated attackers with administrator-level access to inject arbitrary web scripts in pages that execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.",
 "plugin": {
  "slug": "woo-product-slider",
  "name": "Product Slider for WooCommerce",
  "full_name": "Product Slider, Product Carousel and Product Grid Gallery for WooCommerce – Reno Product Slider (formerly Product Slider for WooCommerce)",
  "wordpress_org": "https://wordpress.org/plugins/woo-product-slider/",
  "advisories_url": "https://wpsec.com/vuln/plugin/woo-product-slider/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/woo-product-slider"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 4.4,
  "vector": "CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": "2.8.7",
    "from_inclusive": true,
    "to": "2.9.1",
    "to_inclusive": false
   }
  ],
  "text": [
   "from 2.8.7 before 2.9.1"
  ]
 },
 "introduced_in": "2.8.7",
 "fixed_in": "2.9.1",
 "remediation": "Update to 2.9.1 or later.",
 "fix_released": "2026-10-30T12:09:40+00:00",
 "published": "2026-11-03T14:48:33+00:00",
 "updated": "2026-11-03T13:31:25.995006+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2290/",
  "https://plugins.svn.wordpress.org/woo-product-slider/tags/2.9.1/",
  "https://wordpress.org/plugins/woo-product-slider/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/woo-product-slider",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Low",
  "as_of": "2026-11-03"
 }
}