{
 "id": "WPSEC-2026-2295",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2295/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2295/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2295/index.md",
 "title": "Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder <= 6.2.16 - Authenticated (Fluent Forms Manager+) Server-Side Request Forgery via Mailchimp API Key",
 "description": "The Fluent Forms plugin for WordPress is vulnerable to Server-Side Request Forgery via the Mailchimp API key in the global settings in all versions up to, and including, 6.2.16, due to the data-center part of the API key being placed into the API request host without validation. This makes it possible for authenticated attackers who are Fluent Forms managers with settings-manager permission to make HTTPS GET requests to arbitrary hosts from the web application, which can be used to reach internal services.",
 "plugin": {
  "slug": "fluentform",
  "name": "Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder",
  "full_name": "Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder",
  "wordpress_org": "https://wordpress.org/plugins/fluentform/",
  "advisories_url": "https://wpsec.com/vuln/plugin/fluentform/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/fluentform"
 },
 "type": "SSRF",
 "cwe": [
  "CWE-918"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 5.5,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "6.2.17",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 6.2.17"
  ]
 },
 "introduced_in": null,
 "fixed_in": "6.2.17",
 "remediation": "Update to 6.2.17 or later.",
 "fix_released": "2026-11-02T10:49:18+00:00",
 "published": "2026-11-03T14:48:33+00:00",
 "updated": "2026-11-03T13:38:18.596034+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2295/",
  "https://plugins.svn.wordpress.org/fluentform/tags/6.2.17/",
  "https://wordpress.org/plugins/fluentform/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/fluentform",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "High",
  "affected_versions": "High",
  "as_of": "2026-11-03"
 }
}