{
 "id": "WPSEC-2026-2307",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2307/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2307/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2307/index.md",
 "title": "MetForm – Contact Form, Survey, Quiz, Conditional Forms, Form Templates & Custom Form Builder for Elementor <= 4.3.3 - Authenticated (Contributor+) Missing Authorization to Published Form Creation",
 "description": "The MetForm plugin for WordPress is vulnerable to unauthorized form creation in all versions up to, and including, 4.3.3 due to insufficient capability checks. The 'metform-new-builder' admin action only required the edit_posts capability, and the Form widget's render routine created a form from the template descriptor stored in the 'mf_form_id' widget setting on any render, including frontend views, without checking whether the user or post author could publish forms. This makes it possible for authenticated attackers with Contributor-level access and above to create published MetForm forms, including forms with attacker-controlled content, which they would normally not be permitted to publish.",
 "plugin": {
  "slug": "metform",
  "name": "MetForm – Contact Form, Survey, Quiz, Conditional Forms, Form Templates & Custom Form Builder for Elementor",
  "full_name": "MetForm – Contact Form, Survey, Quiz, Conditional Forms, Form Templates & Custom Form Builder for Elementor",
  "wordpress_org": "https://wordpress.org/plugins/metform/",
  "advisories_url": "https://wpsec.com/vuln/plugin/metform/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/metform"
 },
 "type": "NO AUTHORISATION",
 "cwe": [
  "CWE-862"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 4.3,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "4.3.4",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 4.3.4"
  ]
 },
 "introduced_in": null,
 "fixed_in": "4.3.4",
 "remediation": "Update to 4.3.4 or later.",
 "fix_released": "2026-11-02T08:11:30+00:00",
 "published": "2026-11-03T14:48:33+00:00",
 "updated": "2026-11-03T13:38:43.117012+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2307/",
  "https://plugins.svn.wordpress.org/metform/tags/4.3.4/",
  "https://wordpress.org/plugins/metform/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/metform",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "High",
  "affected_versions": "High",
  "as_of": "2026-11-03"
 }
}