# Easy Social Icons <= 4.0.2 - Authenticated (Administrator+) Stored Cross-Site Scripting via Icon Colour Settings and Icon Titles

- **ID:** WPSEC-2026-2327
- **Plugin:** Easy Social Icons (`easy-social-icons`), https://wordpress.org/plugins/easy-social-icons/
- **Affected versions:** all versions before 4.0.3
- **Fixed in:** 4.0.3 (Update to 4.0.3 or later.)
- **Severity:** Medium 4.4 (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/easy-social-icons
- **Fix released:** 2026-11-01
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2327/

## Description

The Easy Social Icons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the icon colour settings and the icon title in all versions up to, and including, 4.0.2, due to insufficient input sanitization and output escaping. The colour settings were registered without sanitization and printed unescaped into an inline stylesheet on every front-end page, and icon titles were printed unescaped into HTML attributes of the front-end icon markup. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

## References

- https://wpsec.com/vuln/WPSEC-2026-2327/
- https://plugins.svn.wordpress.org/easy-social-icons/tags/4.0.3/
- https://wordpress.org/plugins/easy-social-icons/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2327/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
