{
 "id": "WPSEC-2026-2328",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2328/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2328/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2328/index.md",
 "title": "Co-Authors Plus <= 4.1.3 - Authenticated (Contributor+) Missing Authorization to Guest Author Creation and Modification",
 "description": "The Co-Authors Plus plugin for WordPress is vulnerable to unauthorized modification of data via the guest author profile screens, the guest author custom fields and the '/wp/v2/guest-author' REST route in all versions up to, and including, 4.1.3, due to the guest-author post type being registered with the default post capabilities instead of the 'list_users' capability required by the Guest Authors screen, and to slug collision checks that only covered existing guest authors and users who are members of the current site. This makes it possible for authenticated attackers, with contributor-level access and above, to create and edit guest author profiles, including setting the guest author's linked account through WordPress's generic custom field handling, and to create a guest author whose slug matches a WordPress user who is not a member of the current site, so that the user's bylines resolve to the attacker-controlled profile. Editors could additionally edit and delete any guest author.",
 "plugin": {
  "slug": "co-authors-plus",
  "name": "Co-Authors Plus",
  "full_name": "Co-Authors Plus",
  "wordpress_org": "https://wordpress.org/plugins/co-authors-plus/",
  "advisories_url": "https://wpsec.com/vuln/plugin/co-authors-plus/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/co-authors-plus"
 },
 "type": "NO AUTHORISATION",
 "cwe": [
  "CWE-862"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 4.3,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": "3.0",
    "from_inclusive": true,
    "to": "4.2.0",
    "to_inclusive": false
   }
  ],
  "text": [
   "from 3.0 before 4.2.0"
  ]
 },
 "introduced_in": "3.0",
 "fixed_in": "4.2.0",
 "remediation": "Update to 4.2.0 or later.",
 "fix_released": "2026-10-30T12:24:03+00:00",
 "published": "2026-11-03T14:48:33+00:00",
 "updated": "2026-11-03T13:39:16.220853+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2328/",
  "https://plugins.svn.wordpress.org/co-authors-plus/tags/4.2.0/",
  "https://wordpress.org/plugins/co-authors-plus/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/co-authors-plus",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-11-03"
 }
}