# Co-Authors Plus <= 4.1.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Byline Template Tags

- **ID:** WPSEC-2026-2329
- **Plugin:** Co-Authors Plus (`co-authors-plus`), https://wordpress.org/plugins/co-authors-plus/
- **Affected versions:** all versions before 4.2.0
- **Fixed in:** 4.2.0 (Update to 4.2.0 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/co-authors-plus
- **Fix released:** 2026-10-30
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2329/

## Description

The Co-Authors Plus plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plain byline template tags (such as coauthors()) in all versions up to, and including, 4.1.3 due to insufficient output escaping of co-author field values, tag values and the user_login fallback in coauthors__echo(). This makes it possible for authenticated attackers, with contributor-level access and above, who can write raw guest author profile meta such as the display name, to inject arbitrary web scripts in pages that will execute whenever a user accesses a page displaying the byline.

## References

- https://wpsec.com/vuln/WPSEC-2026-2329/
- https://plugins.svn.wordpress.org/co-authors-plus/tags/4.2.0/
- https://wordpress.org/plugins/co-authors-plus/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2329/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
