# Co-Authors Plus <= 4.1.3 - Unauthenticated Sensitive Information Exposure via '/wp/v2/coauthors' REST Route

- **ID:** WPSEC-2026-2330
- **Plugin:** Co-Authors Plus (`co-authors-plus`), https://wordpress.org/plugins/co-authors-plus/
- **Affected versions:** from 3.5 before 4.2.0
- **Fixed in:** 4.2.0 (Update to 4.2.0 or later.)
- **Severity:** Medium 5.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Medium, affected versions Low (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/co-authors-plus
- **Fix released:** 2026-10-30
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2330/

## Description

The Co-Authors Plus plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.1.3 via the '/wp/v2/coauthors' REST route. The author taxonomy was exposed through the default core terms controller without any permission check, and author term names are user logins. This makes it possible for unauthenticated attackers to enumerate the login names of users on the site, which WordPress core otherwise keeps out of anonymous REST responses.

## References

- https://wpsec.com/vuln/WPSEC-2026-2330/
- https://plugins.svn.wordpress.org/co-authors-plus/tags/4.2.0/
- https://wordpress.org/plugins/co-authors-plus/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2330/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
