# LatePoint <= 5.7.6 - Authenticated (Agent+) Insecure Direct Object Reference to Transaction Modification via 'transactions[id]' Parameter

- **ID:** WPSEC-2026-2335
- **Plugin:** Appointment Booking Plugin – LatePoint | Calendar & Scheduling for WordPress (`latepoint`), https://wordpress.org/plugins/latepoint/
- **Affected versions:** all versions before 5.7.7
- **Fixed in:** 5.7.7 (Update to 5.7.7 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-639
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/latepoint
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2335/

## Description

The LatePoint plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 5.7.6, due to the order save handler loading a transaction by its client-supplied 'id' without verifying that it belongs to the order being saved. This makes it possible for authenticated attackers, with LatePoint Agent-level access and above, to reassign and modify transaction records belonging to orders outside their allowed records.

## References

- https://wpsec.com/vuln/WPSEC-2026-2335/
- https://plugins.svn.wordpress.org/latepoint/tags/5.7.7/
- https://wordpress.org/plugins/latepoint/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2335/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
