# LatePoint <= 5.7.6 - Authenticated (Agent+) Account Takeover of Subscriber-Level Users via 'wordpress_user_id' Parameter

- **ID:** WPSEC-2026-2338
- **Plugin:** Appointment Booking Plugin – LatePoint | Calendar & Scheduling for WordPress (`latepoint`), https://wordpress.org/plugins/latepoint/
- **Affected versions:** all versions before 5.7.7
- **Fixed in:** 5.7.7 (Update to 5.7.7 or later.)
- **Severity:** Medium 4.2 (CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N)
- **Weakness:** CWE-269
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/latepoint
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2338/

## Description

The LatePoint plugin for WordPress is vulnerable to Privilege Escalation via Account Takeover in all versions up to, and including, 5.7.6, due to the customer create and update handlers and the order editor accepting the 'wordpress_user_id' and 'password' fields from any LatePoint backend user. This makes it possible for authenticated attackers, with LatePoint Agent-level access and above, to link a customer record they control to an existing subscriber- or customer-level WordPress account and set that account's password through the customer password reset, on sites with the 'Use WordPress users as customers' option enabled.

## References

- https://wpsec.com/vuln/WPSEC-2026-2338/
- https://plugins.svn.wordpress.org/latepoint/tags/5.7.7/
- https://wordpress.org/plugins/latepoint/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2338/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
