# WP Compress <= 7.30.35 - Cross-Site Request Forgery to Lite Connect

- **ID:** WPSEC-2026-2340
- **Plugin:** WP Compress – Instant Performance & Speed Optimization (`wp-compress-image-optimizer`), https://wordpress.org/plugins/wp-compress-image-optimizer/
- **Affected versions:** all versions before 7.30.45
- **Fixed in:** 7.30.45 (Update to 7.30.45 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-352
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wp-compress-image-optimizer
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2340/

## Description

The WP Compress plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 7.30.35. This is due to missing nonce validation on the wps_lite_connect AJAX action. This makes it possible for unauthenticated attackers to run the plugin's Lite connection flow with a forged request, which overwrites the site's stored API key with a newly issued Lite key and switches the plugin to Lite mode, granted they can trick a site administrator into performing an action such as clicking on a link.

## References

- https://wpsec.com/vuln/WPSEC-2026-2340/
- https://plugins.svn.wordpress.org/wp-compress-image-optimizer/tags/7.30.45/
- https://wordpress.org/plugins/wp-compress-image-optimizer/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2340/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
