# WP Sort Order <= 1.3.6 - Authenticated (Administrator+) Stored Cross-Site Scripting via Extras Order Setting

- **ID:** WPSEC-2026-2343
- **Plugin:** WP Sort Order (`wp-sort-order`), https://wordpress.org/plugins/wp-sort-order/
- **Affected versions:** all versions before 1.3.7
- **Fixed in:** 1.3.7 (Update to 1.3.7 or later.)
- **Severity:** Medium 4.4 (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Medium, affected versions Low (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wp-sort-order
- **Fix released:** 2026-10-31
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2343/

## Description

The WP Sort Order plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the wpso_extras_order option in all versions up to, and including, 1.3.6 due to insufficient input sanitization and output escaping, as the stored values are echoed unescaped into inline JavaScript in the admin footer. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject arbitrary web scripts in admin pages that will execute whenever a user accesses an affected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

## References

- https://wpsec.com/vuln/WPSEC-2026-2343/
- https://plugins.svn.wordpress.org/wp-sort-order/tags/1.3.7/
- https://wordpress.org/plugins/wp-sort-order/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2343/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
