# Photo Gallery – Responsive Image Galleries by Supsystic <= 1.21.6 - Authenticated (Administrator+) Stored Cross-Site Scripting via Social Sharing HTML Gallery Setting

- **ID:** WPSEC-2026-2344
- **Plugin:** Photo Gallery by Supsystic – Image Gallery, Masonry, Albums & Lightbox (`gallery-by-supsystic`), https://wordpress.org/plugins/gallery-by-supsystic/
- **Affected versions:** all versions before 1.21.7
- **Fixed in:** 1.21.7 (Update to 1.21.7 or later.)
- **Severity:** Medium 4.4 (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/gallery-by-supsystic
- **Fix released:** 2026-10-30
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2344/

## Description

The Photo Gallery by Supsystic plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the socialSharing.html gallery setting in all versions up to, and including, 1.21.6 due to insufficient input sanitization on save and missing output escaping in the gallery shortcode template. This makes it possible for authenticated attackers with administrator-level permissions and above to inject arbitrary web scripts in pages that will execute whenever a user accesses a page containing the gallery. This only affects multi-site installations and installations where unfiltered_html has been disabled.

## References

- https://wpsec.com/vuln/WPSEC-2026-2344/
- https://plugins.svn.wordpress.org/gallery-by-supsystic/tags/1.21.7/
- https://wordpress.org/plugins/gallery-by-supsystic/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2344/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
