# WCFM – Frontend Manager for WooCommerce <= 6.8.1 - Authenticated (Vendor+) Missing Authorization to Site-Wide Capability Settings Modification

- **ID:** WPSEC-2026-2347
- **Plugin:** WCFM – Frontend Manager for WooCommerce (`wc-frontend-manager`), https://wordpress.org/plugins/wc-frontend-manager/
- **Affected versions:** all versions before 6.8.2
- **Fixed in:** 6.8.2 (Update to 6.8.2 or later.)
- **Severity:** Medium 6.5 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N)
- **Weakness:** CWE-862
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wc-frontend-manager
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2347/

## Description

The WCFM – Frontend Manager for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data via the 'wcfm-capability' AJAX controller in all versions up to, and including, 6.8.1, due to a missing capability check: the handler only requires 'manage_woocommerce' or 'shop_staff', and the plugin itself gives the vendor role 'manage_woocommerce'. This makes it possible for authenticated attackers with vendor-level access and above to overwrite the site-wide capability settings that restrict all vendors, shop managers and shop staff.

## References

- https://wpsec.com/vuln/WPSEC-2026-2347/
- https://plugins.svn.wordpress.org/wc-frontend-manager/tags/6.8.2/
- https://wordpress.org/plugins/wc-frontend-manager/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2347/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
