# Welcart e-Commerce <= 2.12.6 - Unauthenticated Reflected Cross-Site Scripting via Payment Error Page Parameters

- **ID:** WPSEC-2026-2354
- **Plugin:** Welcart e-Commerce (`usc-e-shop`), https://wordpress.org/plugins/usc-e-shop/
- **Affected versions:** all versions before 2.12.7
- **Fixed in:** 2.12.7 (Update to 2.12.7 or later.)
- **Severity:** Medium 6.1 (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/usc-e-shop
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2354/

## Description

The Welcart e-Commerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'ResponseCd' (WelcartPay/e-SCOTT) and 'err_code' (ZEUS) parameters on the payment error page in all versions up to, and including, 2.12.6 due to insufficient output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Exploitation requires the corresponding payment module to be in use.

## References

- https://wpsec.com/vuln/WPSEC-2026-2354/
- https://plugins.svn.wordpress.org/usc-e-shop/tags/2.12.7/
- https://wordpress.org/plugins/usc-e-shop/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2354/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
