# Welcart e-Commerce <= 2.12.6 - Unauthenticated Arbitrary Shortcode Execution via Inquiry Form

- **ID:** WPSEC-2026-2355
- **Plugin:** Welcart e-Commerce (`usc-e-shop`), https://wordpress.org/plugins/usc-e-shop/
- **Affected versions:** all versions before 2.12.7
- **Fixed in:** 2.12.7 (Update to 2.12.7 or later.)
- **Severity:** High 7.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L)
- **Weakness:** CWE-94
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/usc-e-shop
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2355/

## Description

The Welcart e-Commerce plugin for WordPress is vulnerable to Arbitrary Shortcode Execution via the inquiry form in all versions up to, and including, 2.12.6 due to the sender-supplied inquiry content being passed through do_shortcode when building the customer and manager inquiry e-mails. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. The sender's input was also inserted unescaped into HTML inquiry mails, allowing HTML injection.

## References

- https://wpsec.com/vuln/WPSEC-2026-2355/
- https://plugins.svn.wordpress.org/usc-e-shop/tags/2.12.7/
- https://wordpress.org/plugins/usc-e-shop/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2355/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
