# WowStore <= 4.6.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Product Block Attributes

- **ID:** WPSEC-2026-2359
- **Plugin:** WowStore – Store Builder & Product Blocks for WooCommerce (`product-blocks`), https://wordpress.org/plugins/product-blocks/
- **Affected versions:** from 4.0.0 before 4.6.1
- **Fixed in:** 4.6.1 (Update to 4.6.1 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/product-blocks
- **Fix released:** 2026-10-30
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2359/

## Description

The Store Builder & Product Blocks for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'tooltipPosition' and 'className' attributes of its product grid and list blocks in versions 4.0.0 up to, and including, 4.6.0 due to insufficient output escaping. This makes it possible for authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-2359/
- https://plugins.svn.wordpress.org/product-blocks/tags/4.6.1/
- https://wordpress.org/plugins/product-blocks/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2359/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
