# All In One Login <= 2.5.0 - Authenticated (Administrator+) Missing Authorization to Network Settings Disclosure

- **ID:** WPSEC-2026-2365
- **Plugin:** All In One Login (`change-wp-admin-login`), https://wordpress.org/plugins/change-wp-admin-login/
- **Affected versions:** from 2.5.0 before 2.5.1
- **Fixed in:** 2.5.1 (Update to 2.5.1 or later.)
- **Severity:** Low 2.7 (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-285
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/change-wp-admin-login
- **Fix released:** 2026-10-30
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2365/

## Description

The All In One Login plugin for WordPress is vulnerable to unauthorized access of data due to an insufficient permission check on the network settings REST read endpoint in version 2.5.0. The endpoint allowed any user with the manage_options capability, not only network administrators, to read the network settings payload, which includes stored captcha secret keys and the list of sites on the network. This makes it possible for authenticated attackers with site-level Administrator access on a multisite network to read network-level settings that should be restricted to Super Admins.

## References

- https://wpsec.com/vuln/WPSEC-2026-2365/
- https://plugins.svn.wordpress.org/change-wp-admin-login/tags/2.5.1/
- https://wordpress.org/plugins/change-wp-admin-login/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2365/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
