# WCFM Marketplace <= 3.8.3 - Authenticated (Store Vendor+) Stored Cross-Site Scripting via Store Phone, Email, Support and Social Profile Fields

- **ID:** WPSEC-2026-2375
- **Plugin:** WCFM Marketplace – Multivendor Marketplace for WooCommerce (`wc-multivendor-marketplace`), https://wordpress.org/plugins/wc-multivendor-marketplace/
- **Affected versions:** all versions before 3.8.4
- **Fixed in:** 3.8.4 (Update to 3.8.4 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wc-multivendor-marketplace
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2375/

## Description

The WCFM Marketplace plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the vendor store phone, email, customer support and social profile fields in all versions up to, and including, 3.8.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers with vendor-level access to inject arbitrary web scripts that execute whenever a user, including an administrator, views the store page, the product page's store tab, the [wcfm_store_info] shortcode output or the admin vendor list.

## References

- https://wpsec.com/vuln/WPSEC-2026-2375/
- https://plugins.svn.wordpress.org/wc-multivendor-marketplace/tags/3.8.4/
- https://wordpress.org/plugins/wc-multivendor-marketplace/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2375/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
