# WP User Merger <= 1.6.5 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Display Name

- **ID:** WPSEC-2026-2377
- **Plugin:** WP User Merger (`wp-user-merger`), https://wordpress.org/plugins/wp-user-merger/
- **Affected versions:** all versions before 1.6.6
- **Fixed in:** 1.6.6 (Update to 1.6.6 or later.)
- **Severity:** Medium 5.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wp-user-merger
- **Fix released:** 2026-10-30
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2377/

## Description

The WP User Merger plugin for WordPress is vulnerable to Stored Cross-Site Scripting via a user's display name on the plugin's merge page in all versions up to, and including, 1.6.5 due to insufficient output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject web scripts into their profile that execute if an administrator selects that user for a merge and performs a further action on the page.

## References

- https://wpsec.com/vuln/WPSEC-2026-2377/
- https://plugins.svn.wordpress.org/wp-user-merger/tags/1.6.6/
- https://wordpress.org/plugins/wp-user-merger/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2377/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
