# GeoDirectory <= 2.8.200 - Authenticated (Contributor+) Stored Cross-Site Scripting via gd_dynamic_content Shortcode

- **ID:** WPSEC-2026-2381
- **Plugin:** GeoDirectory – WP Business Directory Plugin and Classified Listings Directory (`geodirectory`), https://wordpress.org/plugins/geodirectory/
- **Affected versions:** all versions before 2.8.201
- **Fixed in:** 2.8.201 (Update to 2.8.201 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/geodirectory
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2381/

## Description

The GeoDirectory plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'html' attribute of the gd_dynamic_content shortcode in all versions up to, and including, 2.8.200. This is due to insufficient input sanitization and output escaping of the attribute and of the HTML built from %%variable%% replacement with listing field values. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-2381/
- https://plugins.svn.wordpress.org/geodirectory/tags/2.8.201/
- https://wordpress.org/plugins/geodirectory/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2381/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
