# GeoDirectory <= 2.8.200 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Nested Shortcode Injection in Listing Content

- **ID:** WPSEC-2026-2382
- **Plugin:** GeoDirectory – WP Business Directory Plugin and Classified Listings Directory (`geodirectory`), https://wordpress.org/plugins/geodirectory/
- **Affected versions:** all versions before 2.8.201
- **Fixed in:** 2.8.201 (Update to 2.8.201 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/geodirectory
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2382/

## Description

The GeoDirectory plugin for WordPress is vulnerable to Stored Cross-Site Scripting via listing content in all versions up to, and including, 2.8.200. This is due to the content sanitizer stripping shortcodes in a single pass, so nested input such as a shortcode name split by an inner shortcode is reassembled into a working shortcode once the inner one is removed. This makes it possible for authenticated attackers, with subscriber-level access and above who can submit listings, to execute arbitrary shortcodes such as gd_dynamic_content with HTML and inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-2382/
- https://plugins.svn.wordpress.org/geodirectory/tags/2.8.201/
- https://wordpress.org/plugins/geodirectory/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2382/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
