{
 "id": "WPSEC-2026-2387",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2387/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2387/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2387/index.md",
 "title": "Smush – Lazy Load Images, Optimize & Compress Images <= 4.3.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Elementor Image URLs",
 "description": "The Smush plugin for WordPress is vulnerable to Stored Cross-Site Scripting via URLs in rendered Elementor content in versions 3.20.0 up to, and including, 4.3.5 due to an overly permissive URL-matching regular expression and insufficient sanitization in the URL replacement routine, which decoded JSON-escaped characters such as angle brackets, quotes and equals signs and wrote them back into the rendered content. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages built with Elementor that will execute whenever a user accesses an injected page. Exploitation requires Elementor to be active.",
 "plugin": {
  "slug": "wp-smushit",
  "name": "Smush – Lazy Load Images, Optimize & Compress Images",
  "full_name": "Smush – Image Optimization, Compression, Lazy Load, WebP & CDN",
  "wordpress_org": "https://wordpress.org/plugins/wp-smushit/",
  "advisories_url": "https://wpsec.com/vuln/plugin/wp-smushit/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/wp-smushit"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": "3.20.0",
    "from_inclusive": true,
    "to": "4.3.6",
    "to_inclusive": false
   }
  ],
  "text": [
   "from 3.20.0 before 4.3.6"
  ]
 },
 "introduced_in": "3.20.0",
 "fixed_in": "4.3.6",
 "remediation": "Update to 4.3.6 or later.",
 "fix_released": "2026-11-02T14:10:34+00:00",
 "published": "2026-11-03T14:48:33+00:00",
 "updated": "2026-11-03T13:38:13.175446+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2387/",
  "https://plugins.svn.wordpress.org/wp-smushit/tags/4.3.6/",
  "https://wordpress.org/plugins/wp-smushit/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/wp-smushit",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "High",
  "affected_versions": "High",
  "as_of": "2026-11-03"
 }
}