# Smush – Lazy Load Images, Optimize & Compress Images <= 4.3.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Elementor Image URLs

- **ID:** WPSEC-2026-2387
- **Plugin:** Smush – Image Optimization, Compression, Lazy Load, WebP & CDN (`wp-smushit`), https://wordpress.org/plugins/wp-smushit/
- **Affected versions:** from 3.20.0 before 4.3.6
- **Fixed in:** 4.3.6 (Update to 4.3.6 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin High, affected versions High (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wp-smushit
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2387/

## Description

The Smush plugin for WordPress is vulnerable to Stored Cross-Site Scripting via URLs in rendered Elementor content in versions 3.20.0 up to, and including, 4.3.5 due to an overly permissive URL-matching regular expression and insufficient sanitization in the URL replacement routine, which decoded JSON-escaped characters such as angle brackets, quotes and equals signs and wrote them back into the rendered content. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages built with Elementor that will execute whenever a user accesses an injected page. Exploitation requires Elementor to be active.

## References

- https://wpsec.com/vuln/WPSEC-2026-2387/
- https://plugins.svn.wordpress.org/wp-smushit/tags/4.3.6/
- https://wordpress.org/plugins/wp-smushit/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2387/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
