# Advanced Woo Search <= 3.73 - Unauthenticated Sensitive Information Exposure via Search Results Cache

- **ID:** WPSEC-2026-2409
- **Plugin:** Advanced Woo Search – Product Search for WooCommerce (`advanced-woo-search`), https://wordpress.org/plugins/advanced-woo-search/
- **Affected versions:** all versions before 3.74
- **Fixed in:** 3.74 (Update to 3.74 or later.)
- **Severity:** Low 3.1 (CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-524
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/advanced-woo-search
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2409/

## Description

The Advanced Woo Search plugin for WordPress is vulnerable to Sensitive Information Exposure via the search results cache in all versions up to, and including, 3.73. Logged-in users with no role on the site shared one cache entry with logged-out visitors. This makes it possible for unauthenticated attackers to read search results cached for such a user, including products that another plugin hides from logged-out visitors, when search caching is on and such a user has searched the same term.

## References

- https://wpsec.com/vuln/WPSEC-2026-2409/
- https://plugins.svn.wordpress.org/advanced-woo-search/tags/3.74/
- https://wordpress.org/plugins/advanced-woo-search/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2409/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
