# Elementor <= 4.3.5 - Reflected Cross-Site Scripting via 'active-tab' and 'active-document' Parameters

- **ID:** WPSEC-2026-2415
- **Plugin:** Elementor Website Builder – more than just a page builder (`elementor`), https://wordpress.org/plugins/elementor/
- **Affected versions:** from 3.21.0 before 4.3.6
- **Fixed in:** 4.3.6 (Update to 4.3.6 or later.)
- **Severity:** Medium 6.1 (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin High, affected versions High (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/elementor
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2415/

## Description

The Elementor Website Builder plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'active-tab' and 'active-document' parameters in versions 3.21.0 up to, and including, 4.3.5 due to insufficient input sanitization of these values when they are added to the Edit with Elementor link, and insufficient output escaping of that link. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user, such as an administrator, into performing an action like clicking on a link.

## References

- https://wpsec.com/vuln/WPSEC-2026-2415/
- https://plugins.svn.wordpress.org/elementor/tags/4.3.6/
- https://wordpress.org/plugins/elementor/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2415/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
