# Elementor <= 4.3.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Atomic Element ID

- **ID:** WPSEC-2026-2416
- **Plugin:** Elementor Website Builder – more than just a page builder (`elementor`), https://wordpress.org/plugins/elementor/
- **Affected versions:** from 4.1.0 before 4.3.6
- **Fixed in:** 4.3.6 (Update to 4.3.6 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin High, affected versions High (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/elementor
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2416/

## Description

The Elementor Website Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Atomic element IDs in versions 4.1.0 up to, and including, 4.3.5 due to element IDs being concatenated into Alpine.js expressions in atomic widget templates without restricting them to safe identifier characters. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary JavaScript that will execute whenever a user accesses an affected page. Exploitation requires the Atomic Widgets feature to be active, which is the default on sites first installed at version 4.0.0 or later.

## References

- https://wpsec.com/vuln/WPSEC-2026-2416/
- https://plugins.svn.wordpress.org/elementor/tags/4.3.6/
- https://wordpress.org/plugins/elementor/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2416/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
