# Advanced Custom Fields (ACF®) <= 6.8.10 - Unauthenticated Sensitive Information Exposure via Password-Protected Post Field Values

- **ID:** WPSEC-2026-2423
- **Plugin:** Advanced Custom Fields (ACF®) (`advanced-custom-fields`), https://wordpress.org/plugins/advanced-custom-fields/
- **Affected versions:** all versions before 6.8.11
- **Fixed in:** 6.8.11 (Update to 6.8.11 or later.)
- **Severity:** Medium 5.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/advanced-custom-fields
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2423/

## Description

The Advanced Custom Fields (ACF®) plugin for WordPress is vulnerable to Sensitive Information Exposure via the REST API, the [acf] shortcode, block bindings and JSON-LD output in all versions up to, and including, 6.8.10. This is due to field values being loaded and output without checking whether the post is password protected and its password has been entered. This makes it possible for unauthenticated attackers to read ACF field values of password-protected posts without knowing the password, for example through the REST API when the field group is shown in REST.

## References

- https://wpsec.com/vuln/WPSEC-2026-2423/
- https://plugins.svn.wordpress.org/advanced-custom-fields/tags/6.8.11/
- https://wordpress.org/plugins/advanced-custom-fields/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2423/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
