# BuddyDrive <= 2.1.4 - Authenticated (Subscriber+) Sensitive Information Exposure via Group Lookup

- **ID:** WPSEC-2026-2426
- **Plugin:** BuddyDrive (`buddydrive`), https://wordpress.org/plugins/buddydrive/
- **Affected versions:** all versions before 2.1.5
- **Fixed in:** 2.1.5 (Update to 2.1.5 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/buddydrive
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2426/

## Description

The BuddyDrive plugin for WordPress is vulnerable to Sensitive Information Exposure via the buddydrive_get_bpobjects AJAX action in all versions up to, and including, 2.1.4, due to the user-supplied user_id parameter being used without an authorization check when groups are looked up. This makes it possible for authenticated attackers, with subscriber-level access and above, to list the BuddyDrive-enabled groups, including hidden groups, that any other user belongs to.

## References

- https://wpsec.com/vuln/WPSEC-2026-2426/
- https://plugins.svn.wordpress.org/buddydrive/tags/2.1.5/
- https://wordpress.org/plugins/buddydrive/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2426/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
