# WP Popular Posts <= 7.4.3 - Unauthenticated Sensitive Information Exposure via 'post_type' Parameter of the Widget REST Endpoint

- **ID:** WPSEC-2026-2431
- **Plugin:** WP Popular Posts (`wordpress-popular-posts`), https://wordpress.org/plugins/wordpress-popular-posts/
- **Affected versions:** from 5.4.0 before 7.4.4
- **Fixed in:** 7.4.4 (Update to 7.4.4 or later.)
- **Severity:** Medium 5.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin High, affected versions High (as of 2026-11-04)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wordpress-popular-posts
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2431/

## Description

The WP Popular Posts plugin for WordPress is vulnerable to Sensitive Information Exposure via the 'post_type' parameter of the /wordpress-popular-posts/v2/widget REST API endpoint in all versions up to, and including, 7.4.3. This is due to the endpoint passing request parameters to the popular posts query without checking them against the public post types. This makes it possible for unauthenticated attackers to list published entries of non-public post types that have views or comments, and to read their titles, links and, through the excerpt option, their content.

## References

- https://wpsec.com/vuln/WPSEC-2026-2431/
- https://plugins.svn.wordpress.org/wordpress-popular-posts/tags/7.4.4/
- https://wordpress.org/plugins/wordpress-popular-posts/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2431/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
