# WP Popular Posts <= 7.4.3 - Unauthenticated Sensitive Information Exposure of Unpublished WPML Translations

- **ID:** WPSEC-2026-2433
- **Plugin:** WP Popular Posts (`wordpress-popular-posts`), https://wordpress.org/plugins/wordpress-popular-posts/
- **Affected versions:** all versions before 7.4.4
- **Fixed in:** 7.4.4 (Update to 7.4.4 or later.)
- **Severity:** Low 3.7 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin High, affected versions High (as of 2026-11-04)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wordpress-popular-posts
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2433/

## Description

The WP Popular Posts plugin for WordPress is vulnerable to Sensitive Information Exposure via the popular posts REST API endpoints and widgets in all versions up to, and including, 7.4.3. This is due to the Translate::get_object_id() function returning the translated post ID from the 'wpml_object_id' filter without checking whether that translation is published. This makes it possible for unauthenticated attackers to view the title, link and content of unpublished (draft, pending or private) translations of popular posts, for example by passing the 'lang' parameter to the /v1/popular-posts endpoint, on sites that use WPML or a compatible multilingual plugin.

## References

- https://wpsec.com/vuln/WPSEC-2026-2433/
- https://plugins.svn.wordpress.org/wordpress-popular-posts/tags/7.4.4/
- https://wordpress.org/plugins/wordpress-popular-posts/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2433/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
