{
 "id": "WPSEC-2026-2435",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2435/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2435/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2435/index.md",
 "title": "Optimole <= 4.2.17 - Authenticated (Contributor+) Stored Cross-Site Scripting via JSON-Escaped Image URLs",
 "description": "The Optimole plugin for WordPress is vulnerable to Stored Cross-Site Scripting via JSON-escaped (slashed) image URLs in all versions up to, and including, 4.2.17, due to insufficient input sanitization and output escaping. When the plugin rewrites image tags, it decodes \\uXXXX escapes and HTML entities in slashed image source URLs and writes parts of the decoded value back into the tag without escaping, including the filename segment of offloaded image URLs. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "optimole-wp",
  "name": "Optimole",
  "full_name": "Optimole – Optimize Images | Convert WebP & AVIF | CDN & Lazy Load | Image Optimization",
  "wordpress_org": "https://wordpress.org/plugins/optimole-wp/",
  "advisories_url": "https://wpsec.com/vuln/plugin/optimole-wp/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/optimole-wp"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "4.2.18",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 4.2.18"
  ]
 },
 "introduced_in": null,
 "fixed_in": "4.2.18",
 "remediation": "Update to 4.2.18 or later.",
 "fix_released": "2026-11-02T20:16:11+00:00",
 "published": "2026-11-03T20:40:54+00:00",
 "updated": "2026-11-03T13:20:22.549325+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2435/",
  "https://plugins.svn.wordpress.org/optimole-wp/tags/4.2.18/",
  "https://wordpress.org/plugins/optimole-wp/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/optimole-wp",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-11-04"
 }
}