# Event Tickets and Registration <= 5.30.3 - Unauthenticated Sensitive Information Exposure via Attendee and Ticket Event Status Filter

- **ID:** WPSEC-2026-2436
- **Plugin:** Event Tickets and Registration (`event-tickets`), https://wordpress.org/plugins/event-tickets/
- **Affected versions:** from 4.8 before 5.30.3.1
- **Fixed in:** 5.30.3.1 (Update to 5.30.3.1 or later.)
- **Severity:** Medium 5.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-863
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-04)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/event-tickets
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2436/

## Description

The Event Tickets and Registration plugin for WordPress is vulnerable to Sensitive Information Exposure via the 'post_status' parameter of the REST API attendee and ticket archive endpoints in all versions up to, and including, 5.30.3. This is due to an incorrect authorization check in the event status filter of the attendee and ticket repositories. For users without the read_private_posts capability, the filter built a publish-only list of statuses, but the query still used the unrestricted statuses the user supplied. This makes it possible for unauthenticated attackers to retrieve attendee and ticket data belonging to private or draft events.

## References

- https://wpsec.com/vuln/WPSEC-2026-2436/
- https://plugins.svn.wordpress.org/event-tickets/tags/5.30.3.1/
- https://wordpress.org/plugins/event-tickets/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2436/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
