# Gallery : FooGallery <= 3.3.17 - Authenticated (Contributor+) Sensitive Information Exposure via Gallery Shortcode and Block

- **ID:** WPSEC-2026-2440
- **Plugin:** FooGallery Photo Gallery : Image, Video & Masonry Galleries (`foogallery`), https://wordpress.org/plugins/foogallery/
- **Affected versions:** all versions before 3.3.26
- **Fixed in:** 3.3.26 (Update to 3.3.26 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-04)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/foogallery
- **Fix released:** 2026-11-03
- **Published:** 2026-11-04
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2440/

## Description

The FooGallery Photo Gallery plugin for WordPress is vulnerable to Sensitive Information Exposure via the foogallery shortcode, the gallery block and the block-renderer REST route in all versions up to, and including, 3.3.17. This is due to the gallery renderer loading a gallery by its ID without checking the gallery's post status. This makes it possible for authenticated attackers, with Contributor-level access and above, to embed or preview private and draft galleries they are not permitted to read and view their images and captions.

## References

- https://wpsec.com/vuln/WPSEC-2026-2440/
- https://plugins.svn.wordpress.org/foogallery/tags/3.3.26/
- https://wordpress.org/plugins/foogallery/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2440/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
