{
 "id": "WPSEC-2026-2452",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2452/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2452/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2452/index.md",
 "title": "The Post Grid – Shortcode, Gutenberg Blocks and Elementor Addon for Post Grid <= 7.9.8 - Authenticated (Contributor+) Sensitive Information Exposure via Password-Protected Post Content",
 "description": "The The Post Grid plugin for WordPress is vulnerable to Sensitive Information Exposure via the 'rttpg_block_css_get_posts' AJAX action (block CSS loader) in all versions up to, and including, 7.9.8, due to an insufficient 'read_post' capability check that does not account for post passwords and returns the raw post_content of any readable post. This makes it possible for authenticated attackers, with Contributor-level access and above, to retrieve the raw content of password-protected posts by supplying their post ID.",
 "plugin": {
  "slug": "the-post-grid",
  "name": "The Post Grid – Shortcode, Gutenberg Blocks and Elementor Addon for Post Grid",
  "full_name": "The Post Grid – Shortcode, Gutenberg Blocks and Elementor Addon for Post Grid",
  "wordpress_org": "https://wordpress.org/plugins/the-post-grid/",
  "advisories_url": "https://wpsec.com/vuln/plugin/the-post-grid/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/the-post-grid"
 },
 "type": "SENSITIVE DATA DISCLOSURE",
 "cwe": [
  "CWE-200"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 4.3,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": "5.0.0",
    "from_inclusive": true,
    "to": "7.9.9",
    "to_inclusive": false
   }
  ],
  "text": [
   "from 5.0.0 before 7.9.9"
  ]
 },
 "introduced_in": "5.0.0",
 "fixed_in": "7.9.9",
 "remediation": "Update to 7.9.9 or later.",
 "fix_released": "2026-11-03T06:59:53+00:00",
 "published": "2026-11-04T07:46:30+00:00",
 "updated": "2026-11-03T13:19:12.964225+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2452/",
  "https://plugins.svn.wordpress.org/the-post-grid/tags/7.9.9/",
  "https://wordpress.org/plugins/the-post-grid/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/the-post-grid",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-11-04"
 }
}