# The Post Grid – Shortcode, Gutenberg Blocks and Elementor Addon for Post Grid <= 7.9.8 - Authenticated (Contributor+) Sensitive Information Exposure via Password-Protected Post Content

- **ID:** WPSEC-2026-2452
- **Plugin:** The Post Grid – Shortcode, Gutenberg Blocks and Elementor Addon for Post Grid (`the-post-grid`), https://wordpress.org/plugins/the-post-grid/
- **Affected versions:** from 5.0.0 before 7.9.9
- **Fixed in:** 7.9.9 (Update to 7.9.9 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-04)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/the-post-grid
- **Fix released:** 2026-11-03
- **Published:** 2026-11-04
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2452/

## Description

The The Post Grid plugin for WordPress is vulnerable to Sensitive Information Exposure via the 'rttpg_block_css_get_posts' AJAX action (block CSS loader) in all versions up to, and including, 7.9.8, due to an insufficient 'read_post' capability check that does not account for post passwords and returns the raw post_content of any readable post. This makes it possible for authenticated attackers, with Contributor-level access and above, to retrieve the raw content of password-protected posts by supplying their post ID.

## References

- https://wpsec.com/vuln/WPSEC-2026-2452/
- https://plugins.svn.wordpress.org/the-post-grid/tags/7.9.9/
- https://wordpress.org/plugins/the-post-grid/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2452/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
