{
 "id": "WPSEC-2026-2456",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2456/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2456/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2456/index.md",
 "title": "TranslatePress <= 3.3.8 - Unauthenticated Stored Cross-Site Scripting via trp-ajax.php Endpoint",
 "description": "The TranslatePress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the standalone trp-ajax.php endpoint in all versions up to, and including, 3.3.8. The endpoint returns stored translation dictionary strings with json_encode() but sends no JSON content type and does not escape HTML characters, so the response can be rendered as HTML when opened as a top-level page. This makes it possible for unauthenticated attackers to execute arbitrary web scripts in the site's origin when a victim is tricked into loading a crafted request to the endpoint, for example through an auto-submitting form, provided a malicious string such as an SVG event handler is present in the translation dictionary.",
 "plugin": {
  "slug": "translatepress-multilingual",
  "name": "TranslatePress",
  "full_name": "TranslatePress – Translate Multilingual sites with AI Translation",
  "wordpress_org": "https://wordpress.org/plugins/translatepress-multilingual/",
  "advisories_url": "https://wpsec.com/vuln/plugin/translatepress-multilingual/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/translatepress-multilingual"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.1,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "3.3.9",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 3.3.9"
  ]
 },
 "introduced_in": null,
 "fixed_in": "3.3.9",
 "remediation": "Update to 3.3.9 or later.",
 "fix_released": "2026-11-03T08:54:11+00:00",
 "published": "2026-11-04T09:46:28+00:00",
 "updated": "2026-11-03T13:38:16.069264+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2456/",
  "https://plugins.svn.wordpress.org/translatepress-multilingual/tags/3.3.9/",
  "https://wordpress.org/plugins/translatepress-multilingual/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/translatepress-multilingual",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "High",
  "affected_versions": "High",
  "as_of": "2026-11-04"
 }
}