{
 "id": "WPSEC-2026-2457",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2457/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2457/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2457/index.md",
 "title": "Spectra Legacy – Gutenberg Blocks <= 2.20.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Counter Block 'data-counter' Attribute",
 "description": "The Spectra Legacy – Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Counter block's 'data-counter' HTML attribute in all versions up to, and including, 2.20.5, due to the front-end counter script parsing options from that attribute in the saved post markup, letting them override the server-generated options, and passing the unsanitized thousand separator value to the CountUp library, which writes the formatted number with innerHTML. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "ultimate-addons-for-gutenberg",
  "name": "Spectra Legacy – Gutenberg Blocks",
  "full_name": "Spectra Legacy – Gutenberg Blocks",
  "wordpress_org": "https://wordpress.org/plugins/ultimate-addons-for-gutenberg/",
  "advisories_url": "https://wpsec.com/vuln/plugin/ultimate-addons-for-gutenberg/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/ultimate-addons-for-gutenberg"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": "2.5.0",
    "from_inclusive": true,
    "to": "2.20.6",
    "to_inclusive": false
   }
  ],
  "text": [
   "from 2.5.0 before 2.20.6"
  ]
 },
 "introduced_in": "2.5.0",
 "fixed_in": "2.20.6",
 "remediation": "Update to 2.20.6 or later.",
 "fix_released": "2026-11-03T09:14:39+00:00",
 "published": "2026-11-04T09:46:28+00:00",
 "updated": "2026-11-03T13:38:45.811434+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2457/",
  "https://plugins.svn.wordpress.org/ultimate-addons-for-gutenberg/tags/2.20.6/",
  "https://wordpress.org/plugins/ultimate-addons-for-gutenberg/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/ultimate-addons-for-gutenberg",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "High",
  "affected_versions": "High",
  "as_of": "2026-11-04"
 }
}