{
 "id": "WPSEC-2026-2460",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2460/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2460/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2460/index.md",
 "title": "Addon Elements for Elementor (formerly Elementor Addon Elements) <= 1.15 - Unauthenticated Sensitive Information Exposure via Post List and Timeline Widgets",
 "description": "The Addon Elements for Elementor (formerly Elementor Addon Elements) plugin for WordPress is vulnerable to Sensitive Information Exposure via the Post List and Timeline widgets in all versions up to, and including, 1.15 due to the widgets rendering the excerpt or content of posts without checking whether the post is password-protected. This makes it possible for unauthenticated attackers to read the excerpt or content of password-protected posts when a page containing one of these widgets lists such posts. Contributor-level users who can build Elementor content could also place these widgets to expose protected posts.",
 "plugin": {
  "slug": "addon-elements-for-elementor-page-builder",
  "name": "Addon Elements for Elementor (formerly Elementor Addon Elements)",
  "full_name": "Addon Elements for Elementor (formerly Elementor Addon Elements)",
  "wordpress_org": "https://wordpress.org/plugins/addon-elements-for-elementor-page-builder/",
  "advisories_url": "https://wpsec.com/vuln/plugin/addon-elements-for-elementor-page-builder/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/addon-elements-for-elementor-page-builder"
 },
 "type": "SENSITIVE DATA DISCLOSURE",
 "cwe": [
  "CWE-200"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 3.7,
  "vector": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N",
  "severity": "Low"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "1.15.1",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 1.15.1"
  ]
 },
 "introduced_in": null,
 "fixed_in": "1.15.1",
 "remediation": "Update to 1.15.1 or later.",
 "fix_released": "2026-11-03T09:41:47+00:00",
 "published": "2026-11-04T09:46:28+00:00",
 "updated": "2026-11-03T13:19:10.331098+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2460/",
  "https://plugins.svn.wordpress.org/addon-elements-for-elementor-page-builder/tags/1.15.1/",
  "https://wordpress.org/plugins/addon-elements-for-elementor-page-builder/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/addon-elements-for-elementor-page-builder",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-11-04"
 }
}