# Addon Elements for Elementor (formerly Elementor Addon Elements) <= 1.15 - Unauthenticated Sensitive Information Exposure via Post List and Timeline Widgets

- **ID:** WPSEC-2026-2460
- **Plugin:** Addon Elements for Elementor (formerly Elementor Addon Elements) (`addon-elements-for-elementor-page-builder`), https://wordpress.org/plugins/addon-elements-for-elementor-page-builder/
- **Affected versions:** all versions before 1.15.1
- **Fixed in:** 1.15.1 (Update to 1.15.1 or later.)
- **Severity:** Low 3.7 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-04)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/addon-elements-for-elementor-page-builder
- **Fix released:** 2026-11-03
- **Published:** 2026-11-04
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2460/

## Description

The Addon Elements for Elementor (formerly Elementor Addon Elements) plugin for WordPress is vulnerable to Sensitive Information Exposure via the Post List and Timeline widgets in all versions up to, and including, 1.15 due to the widgets rendering the excerpt or content of posts without checking whether the post is password-protected. This makes it possible for unauthenticated attackers to read the excerpt or content of password-protected posts when a page containing one of these widgets lists such posts. Contributor-level users who can build Elementor content could also place these widgets to expose protected posts.

## References

- https://wpsec.com/vuln/WPSEC-2026-2460/
- https://plugins.svn.wordpress.org/addon-elements-for-elementor-page-builder/tags/1.15.1/
- https://wordpress.org/plugins/addon-elements-for-elementor-page-builder/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2460/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
