{
 "id": "WPSEC-2026-2471",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2471/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2471/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2471/index.md",
 "title": "Ditty – Responsive News Tickers, Sliders, and Lists <= 3.1.71 - Missing Authorization to Unauthenticated Arbitrary Shortcode Execution via Editor Preview REST Routes",
 "description": "The Ditty plugin for WordPress is vulnerable to unauthorized access via the displayItems, phpItemMods and dynamicLayoutTags REST routes in all versions up to, and including, 3.1.71, due to the general_ditty_permissions_check permission callback returning true for every request. The handlers only verify a wp_rest nonce, and the plugin prints that nonce to logged-out visitors as well. The displayItems route renders item data taken from the request and passes item content through do_shortcode(). This makes it possible for unauthenticated attackers to render arbitrary Ditty preview content and execute arbitrary shortcodes.",
 "plugin": {
  "slug": "ditty-news-ticker",
  "name": "Ditty – Responsive News Tickers, Sliders, and Lists",
  "full_name": "Ditty – Responsive News Tickers, Sliders, and Lists",
  "wordpress_org": "https://wordpress.org/plugins/ditty-news-ticker/",
  "advisories_url": "https://wpsec.com/vuln/plugin/ditty-news-ticker/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/ditty-news-ticker"
 },
 "type": "NO AUTHORISATION",
 "cwe": [
  "CWE-862"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.5,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "3.1.72",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 3.1.72"
  ]
 },
 "introduced_in": null,
 "fixed_in": "3.1.72",
 "remediation": "Update to 3.1.72 or later.",
 "fix_released": "2026-11-03T13:15:24+00:00",
 "published": "2026-11-04T14:58:24+00:00",
 "updated": "2026-11-04T13:57:04.362090+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2471/",
  "https://plugins.svn.wordpress.org/ditty-news-ticker/tags/3.1.72/",
  "https://wordpress.org/plugins/ditty-news-ticker/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/ditty-news-ticker",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-11-04"
 }
}