{
 "id": "WPSEC-2026-2472",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2472/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2472/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2472/index.md",
 "title": "Ditty – Responsive News Tickers, Sliders, and Lists <= 3.1.71 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'display' Shortcode Attribute and Display Style Settings",
 "description": "The Ditty plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'display' attribute of the ditty shortcode and block and the custom display style settings (typography and color values) in all versions up to, and including, 3.1.71. This is due to insufficient input sanitization combined with the display scripts building style and link elements from these values as jQuery HTML strings and writing stylesheet contents with .html(). This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "ditty-news-ticker",
  "name": "Ditty – Responsive News Tickers, Sliders, and Lists",
  "full_name": "Ditty – Responsive News Tickers, Sliders, and Lists",
  "wordpress_org": "https://wordpress.org/plugins/ditty-news-ticker/",
  "advisories_url": "https://wpsec.com/vuln/plugin/ditty-news-ticker/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/ditty-news-ticker"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "3.1.72",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 3.1.72"
  ]
 },
 "introduced_in": null,
 "fixed_in": "3.1.72",
 "remediation": "Update to 3.1.72 or later.",
 "fix_released": "2026-11-03T13:15:24+00:00",
 "published": "2026-11-04T14:58:24+00:00",
 "updated": "2026-11-04T13:57:04.362090+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2472/",
  "https://plugins.svn.wordpress.org/ditty-news-ticker/tags/3.1.72/",
  "https://wordpress.org/plugins/ditty-news-ticker/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/ditty-news-ticker",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-11-04"
 }
}